OS/2, eCS & ArcaOS - Technical > Networking
OpenSSH Server setup on ArcaOS
Martin Iturbide:
Hello
Now it is my turn to get Openssh on ArcaOS, so I can access it from a Windows machine.
I have installed OpenSSH
yum install openssh openssh-server
openssh-8.4p1-5.oc00.pentium4 and openssh-server-8.4p1-5.oc00.pentium4 are installed.
I run with bash
--- Quote ---[C:\usr\sbin]bash
bash-5.0# /usr/sbin/sshd -D
sshd: no hostkeys available -- exiting.
bash-5.0#
--- End quote ---
I created the keys:
--- Quote ---ssh-keygen -t rsa -f c:\etc\ssh\ssh_host_rsa_key
ssh-keygen -t dsa -f c:\etc\ssh\ssh_host_dsa_key
ssh-keygen -t ecdsa -f C:\etc\ssh\ssh_host_ecdsa_key
ssh-keygen -t ed25519 -f c:\etc\ssh\ssh_host_ed25519_key
--- End quote ---
Seems that all keys were created fine.
I run with bash
--- Quote ---[C:\usr\sbin]bash
bash-5.0# /usr/sbin/sshd -D
sshd: no hostkeys available -- exiting.
bash-5.0#
--- End quote ---
So, it still it does not find the keys.
What I'm doing wrong? or what else I'm missing to do?
Thanks in advance.
Steven Levine:
Try running with the debug option
sshd -D -d
The extra output might help.
Martin Iturbide:
Hello
Thanks for the feedback.
Just right now I tried a different approach
It was giving me this issue.
--- Quote ---[C:\]C:\usr\sbin\sshd.exe -d
debug1: sshd version OpenSSH_8.4, OpenSSL 3.4.6 9 Jun 2026
debug1: Unable to load host key "/@unixroot/etc/ssh/ssh_host_rsa_key": incorrect
passphrase supplied to decrypt private key
debug1: Unable to load host key: /@unixroot/etc/ssh/ssh_host_rsa_key
debug1: Unable to load host key "/@unixroot/etc/ssh/ssh_host_ecdsa_key": incorre
ct passphrase supplied to decrypt private key
debug1: Unable to load host key: /@unixroot/etc/ssh/ssh_host_ecdsa_key
debug1: Unable to load host key "/@unixroot/etc/ssh/ssh_host_ed25519_key": incor
rect passphrase supplied to decrypt private key
debug1: Unable to load host key: /@unixroot/etc/ssh/ssh_host_ed25519_key
sshd: no hostkeys available -- exiting.
--- End quote ---
I'm guessing that since I created the keys with a password, you need to put the password somewhere I don't know.
I was recommended to delete the keys and try again
--- Quote ---[C:\ETC\SSH]del ssh-host*.*
--- End quote ---
I tried this way to generate the keys
--- Quote ---[C:\]ssh-keygen -A
ssh-keygen: generating new host keys: RSA DSA ECDSA ED25519
--- End quote ---
Run again the server.
--- Quote ---[C:\]C:\usr\sbin\sshd.exe -d
debug1: sshd version OpenSSH_8.4, OpenSSL 3.4.6 9 Jun 2026
debug1: private host key #0: ssh-rsa SHA256:ByRtqG4qVTacOtWIQuyYOhTIdcmNO4WJ2KAc
fFxlhgo
debug1: private host key #1: ecdsa-sha2-nistp256 SHA256:9sKXxk5sKlu7mEI2we4vVafW
6KzxluyVQkNVbBOluuw
debug1: private host key #2: ssh-ed25519 SHA256:4TBdBd8NgO1jewYEb36JsczrlVlcY+On
VHSsGFPpzo4
debug1: rexec_argv[0]='C:\\usr\\sbin\\sshd.exe'
debug1: rexec_argv[1]='-d'
debug1: Bind to port 22 on 0.0.0.0.
Server listening on 0.0.0.0 port 22.
--- End quote ---
The server runs.
Now I don't know why it says the 0.0.0.0, and I have to check how to manage the users.
Regards
David McKenna:
Martin,
I have been looking at doing this too and have noticed that in the file '\etc\ssh\sshd_config' you have to specify your 'ListenAddress' to the server IP address or else it defaults to 0.0.0.0. Thanks for the tip on creating the keys.
Regards,
Steven Levine:
Good to see that the debug log revealed the source of the problem. You did not mention that you created the keys with a passphrase. I'm a bit surprised that sshd did not prompt for the passphrase. Perhaps it is a build nit or maybe the behavior has changed over the years.
In the past, I've used ssh-agent to cache and supply the passphrase when required.
Navigation
[0] Message Index
[#] Next page
Go to full version